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INSTALLATION INSTRUCTIONS
CEDRA-Avenue Wraps™

Step 1:

The CEDRA Avenue Wraps™  software requires approximately fifteen (15) megabytes of disk
space and will operate under Windows NT®, Windows 2000® and Windows XP®.  One top level
directory, whose default name is CEDRA, will be created.  Should the user wish to use a different
name, the user can do so.  Within the CEDRA directory a file called readme.txt, which describes
the contents of the CEDRA Avenue Wraps distribution directory, will appear.  This file should
be read prior to working with the CEDRA Avenue Wraps software.

It is assumed in this installation discussion, that the "C:" partition will be used to contain the
software.  If this is not the case, it is possible to substitute the appropriate drive identifier when
performing the installation.  It is also assumed that the individual installing the software is
somewhat familiar with PC terminology, has a working knowledge of the PC and the available
text editors that are installed on the PC, and is somewhat familiar with ArcGIS®.

The CEDRA Avenue Wraps software supports the ArcGIS 8.x and 9.x platforms.  The user
should verify which version of ArcGIS is being used at this time.

The CEDRA Avenue Wraps software consists of a single CD and contains the software in a
compressed file format.  An installation program will decompress the compressed file and install
the CEDRA Avenue Wraps software in the desired directory.  Prior to installing the software,
a partition on the PC should be found that contains the necessary amount of free disk space,
fifteen (15) megabytes.

Step 2:

The contents of the CEDRA Avenue Wraps software can now be extracted and stored onto the
PC.  The CD should now be inserted into the appropriate drive.
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Step 3:

Select the Start button from the task bar followed by selecting the Run... menu item.

Step 4:

The CEDRA software installation program can be invoked by typing:

D:SETUP (ArcGIS 8.x Version)
or

D:SETUP9 (ArcGIS 9.x Version)

If the CD drive identifier is something other than D, the user should make the appropriate
substitution in the above command.  Note that there are two installation programs on the CD,
one for the ArcGIS 8.x platform and one for the 9.x platform.  The user should execute only one
of the installation programs.  It is not possible to execute both programs on the same PC.

The installation program will then pose a series of screens guiding the user through the
installation process.  Once the final screen has been displayed, the program will decompress the
compressed file, and store the files in the appropriate directory location.  After the file has been
decompressed, the user can invoke ArcMap and reference the Avenue Wraps ActiveX DLL.

How to Use the CEDRA Avenue Wraps Software:

This version of the CEDRA Avenue Wraps software is available as an ActiveX DLL.  Once the
installation program has finished, within the CEDRA Avenue Wraps distribution directory there
will appear a file called avwraps.dll.  This is the ActiveX DLL that can be referenced by the user
in either (a) an ArcMap document file or (b) a VB project file.

In working with the CEDRA Avenue Wraps software, the developer can: (a) use the ActiveX
DLL file, avwraps.dll, as is or (b) modify the CEDRA Avenue Wraps software in order to create
a new custom ActiveX DLL.  Depending upon the developer's requirements the appropriate
mode of operation can be determined.  Note, if the CEDRA Avenue Wraps software is to be
modified, the developer will need to use Visual Basic 6 and modify the avwraps.vbp file, located
in the dll folder within the CEDRA Avenue Wraps distribution directory.  Once the VB project
file has been modified, a new ActiveX DLL can be built.  In so doing, the developer is able to
customize the CEDRA Avenue Wraps software to meet the developer's specific requirements.
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Getting Started:

The first step in using the CEDRA Avenue Wraps software is to reference the Avenue Wraps
DLL file, avwraps.dll, in your ArcMap document file or your VB project file.  After installing the
CEDRA Avenue Wraps software, within the distribution directory, there will be a file called
avwraps.dll. This file has been registered with Windows as an ActiveX DLL and is ready for
referencing.  This should be the file that is selected in Step 6 below (provided that the CEDRA
Avenue Wraps software is not to be modified by the user).

If the user wishes to modify the CEDRA Avenue Wraps software, the VB project file,
avwraps.vbp, can be modified to create a new DLL version of the CEDRA Avenue Wraps
software.  The avwraps.vbp project file can be found in the dll folder within the CEDRA Avenue
Wraps distribution directory. After the modifications have been made and the DLL built, this
file can be selected in Step 6 below.

The following steps below describe how to reference the avwraps.dll file in a new ArcMap
document file.

➤ 1 Invoke the ArcMap program.

➤ 2 Accept the default selection to create a new empty map, and click at the OK button.

➤ 3 Click at the Tools menu and then at the Macros and Visual Basic Editor sub-menus.

➤ 4 Click at the Tools menu and then at the References... sub-menu.

➤ 5 Click at the Browse button to display the Add Reference file dialog box.

➤ 6 Navigate to the directory in which the avwraps.dll file is located.

➤ 7 Click at the name of the avwraps.dll file.

➤ 8 Click at the Open button.

➤ 9 Click at the OK button to confirm.

➤ 10 Click in the square containing the plus (+) character to the left of the folder called
ArcMap Objects under the Project group in the Project window.
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➤ 11 Double-click on the ThisDocument module name.

➤ 12 Scroll down in the Object drop-down list and select the MxDocument name.

➤ 13 Scroll down in the Procedure drop-down list and select the OpenDocument name.

➤ 14 Insert the line Call avInit(Application) in the OpenDocument procedure.

➤ 15 Click the Run Sub/UserForm tool to execute the subroutine.  This will initialize the
Avenue Wraps global variables.  The avwraps.dll has now been referenced in the VBA
application, and all of the Avenue Wraps are now available to the developer.  The user
can now create new modules and begin to convert existing Avenue code or develop
new code using the Avenue Wraps "wraparounds".

Note that any time a new module is inserted in the ArcMap document file, the
OpenDocument procedure will need to be re-executed.  The OpenDocument procedure
is a good location to perform any initialization that may be required.

The following steps below describe how to reference the avwraps.dll file in a new VB project
file.

➤ 1 Invoke Visual Basic Version 6.0.

➤ 2 Select the New tab, followed by clicking on the Active X DLL icon and then select
the Open button.

➤ 3 Select the Project menu and the References... sub menu item.

➤ 4 Click at the Browse... button to display the Add Reference file dialog box.

➤ 5 Navigate to the directory in which the avwraps.dll file is located.

➤ 6 Click at the name of the avwraps.dll file.

➤ 7 Click at the Open button.

➤ 8 Click in the square to the left of the CEDRA Avenue Wraps reference name.

➤ 9 Click at the OK button to close the Add Reference file dialog box.
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Sample Data:

In addition to the ActiveX DLL file, seven VBA modules and two shapefiles are included
containing sample code and data, which illustrate the use of the CEDRA Avenue Wraps.  These
samples include:

Module1.bas Sample illustrating how to process graphics and symbols, the graphics that
are created are based upon an arbitrary coordinate system.

Module2.bas Sample illustrating how to process feature geometry.  This is done by using
the first selected feature in a polygon theme.

Module3.bas Sample illustrating how to create a Shapefile and add a feature to it.  The sample
will also show how an operation can be defined.

Module4.bas Sample illustrating how to perform various shape editing operations.  This
sample requires seven polygon features and one polyline feature be selected
prior to executing this macro.  The first selected polygon and the selected
polyline features will be used in a split operation. The remaining selected
polygons will be used to demonstrate (a) merging, (b) intersecting and (c)
unioning operations.  The shapefiles L_0pg and L_0pl, which are included
in the distribution set (under the DATA folder within the distribution
directory), can be added to ArcMap and used in this sample.

Module5.bas Sample illustrating how to create, add records, populate and summarize a
table.

Module6.bas Sample illustrating how to create a new shapefile that has a default spatial
reference and three attributes using a name that the user enters in a file dialog
box.  The shapefile is to contain Polyline features and will be added to the map
once it has been created.

Module7.bas Sample illustrating how to create various types of message boxes.

How to Import and Execute a Sample:

➤ 1 Perform Steps 1 through 15 under the Getting Started section of how to reference the
avwraps.dll file in a new ArcMap document file.
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➤ 2 Click at the Tools menu and then at the Macros and Visual Basic Editor sub-menus.

➤ 3 Click at the plus sign, +,  to the left of the Project label in the project window to expand
the project document.

➤ 4 Click at the File menu and then at the Import File... sub-menu.

➤ 5 Navigate to CEDRA Avenue Wraps distribution directory, click on the desired sample
module file name, and then click the Open button.

➤ 6 Click at the plus sign, +,  to the left of the Modules label in the project window to expand
the module document.

➤ 7 Scroll down the list of modules and find the sample module file that was imported.  Once
found, double-click on the name of the module to open the module.

➤ 8 Click at the Run Sub/UserForm tool ( ) to execute the sample code.

Note that with the Module4.bas sample, the L_0pg and L_0pl shapefiles will need to
be loaded prior to performing this exercise.
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CEDRA-ArcView3-Tools Toolbar

As an extra, and totally optional to the user, the CEDRA-ArcView3-Tools toolbar is included
with the CEDRA Avenue Wraps™  software.  This toolbar contains eleven tools, as shown in
Figure 1, which facilitate the interaction between the user and ArcMap.  Users who have
experience with ArcView® GIS will recognize these tools and appreciate their presence in
migrating their applications from ArcView® GIS to ArcGIS.

Presented below is a comparison of how the CEDRA-ArcView3-Tools operate versus their
ArcMap counterpart. The tools are described in a left to right fashion beginning with the left-
most tool, Identify Features From Active Layers. Note that the CEDRA Approach tries to
"streamline" the operation of the tool for which it was designed for.

1. Identify Features
This tool is used to list or identify the attributes that are associated with a selected feature.
CEDRA Approach
◗ Select the layer(s) in the Table of Contents.
◗ Pick the CEDRA-ArcView3-Tools Identify Features tool.
◗ Select the feature in the map to be identified.
ArcMap Approach
◗ Pick the Selection menu item.
◗ Pick the Set Selectable Layers sub menu item.

The CEDRA-
ArcView3-Tools

toolbar contains
tools which

enable the user to
reduce the number

of "clicks" that
are needed to

identify and select
features

Figure 1 - CEDRA-ArcView3-Tools

Sw it ch t he Select io n  S et
Open  Them e T a b le
Delet e Select ed  Fea t ures
M a ke All Them es In v isib le
M a ke All Them es Visib le
Z o o m  T o  S elect ed  In  Act iv e L a yers
Z o o m  T o  Act iv e Them e(s)
Z o o m  T o  Full Ext en t
U n S elect  Fea t ures Fro m  Act iv e L a yers
Select  Fea t ures Fro m  Act iv e L a yers
Id en t ify Fea t ures Fro m  Act iv e L a yers
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◗ Click in the square to the left of the layer(s) that are to be made selectable.
◗ Click the Close button.
◗ Pick the ArcMap Identify tool.
◗ Select the feature in the map to be identified.

2. Select Features
This tool is used to select a feature or group of features in the map.
CEDRA Approach
◗ Select the layer(s) in the Table of Contents.
◗ Pick the CEDRA-ArcView3-Tools Select Features tool.
◗ Select the feature(s) by making a pick or dragging a rectangle in the map.
ArcMap Approach
◗ Pick the Selection menu item.
◗ Pick the Set Selectable Layers sub menu item.
◗ Click in the square to the left of the layer(s) that are to be made selectable.
◗ Click the Close button.
◗ Pick the ArcMap Select Features tool.
◗ Select the feature(s) by making a pick or dragging a rectangle in the map.

3. Clear Selected Features
This tool is used to clear the selection set for the active or selected layers in the map. This
tool will also handle tables in addition to layers.
CEDRA Approach
◗ Select the layer(s) in the Table of Contents.
◗ Click this tool to clear the selection set for the active or selected layers in the map.
ArcMap Approach
◗ Right-click on the name of the layer in the Table of Contents.
◗ Pick the Selection command.
◗ Pick the Clear Selected Features command.
◗ Repeat the above three steps for each layer to be processed.

4. Zoom to Full Extent
This tool is used to zoom to the full extent of the map. There is no difference between the
CEDRA and ArcMap tools which provide this functionality. This tool is only provided
because the icon is familiar to ArcView GIS users.
CEDRA Approach
◗ Click this tool to zoom to the full extent of the map.
ArcMap Approach
◗ Click the ArcMap Full Extent button to zoom to the full extent of the map.
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5. Zoom to Active
This tool is used to zoom to the extent of the active or selected layers in the map.
CEDRA Approach
◗ Select the layer(s) in the Table of Contents.
◗ Click this tool to zoom to the extent of the active or selected layers in the map.
ArcMap Approach
◗ Select the layer(s) in the Table of Contents.
◗ Right-click on one of the active or selected layers and select the Zoom to Layer

command.

6. Zoom to Selected
This tool is used to zoom to the extent of the selected features in the active or selected layers
in the map.
CEDRA Approach
◗ Select the feature(s) to be processed.
◗ Click this tool to zoom to the extent of the selected features in the active or selected

layers in the map.
ArcMap Approach
◗ Select the feature(s) to be processed.
◗ Pick the Selection menu item.
◗ Pick the Zoom to Selected Features sub menu item.

7. Turn All Themes On
This tool is used to make all layers in the map visible.
CEDRA Approach
◗ Click this tool to make all layers in the map visible.
ArcMap Approach
◗ As of this writing there is no equivalent for this tool in ArcMap.

8. Turn All Themes Off
This tool is used to make all layers in the map invisible.
CEDRA Approach
◗ Click this tool to make all layers invisible.
ArcMap Approach
◗ As of this writing there is no equivalent for this tool in ArcMap.
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9. Delete Selected Features
This tool is used to delete the selected feature(s) in the map.
CEDRA Approach
◗ Select the feature(s) to be processed.
◗ Click this tool to delete the selected feature(s) from the map.
ArcMap Approach
◗ Select the feature(s) to be processed.
◗ Pick the Editor button.
◗ Click Start Editing command. If more than one dataset is present, select the dataset to

be edited.
◗ Click the Delete key on the keyboard.

10. Open Theme Table
This tool is used to open the attribute table for the active or selected layers in the map. This
tool will also handle tables in addition to layers.
CEDRA Approach
◗ Select the layer(s) in the Table of Contents.
◗ Click this tool to open the attribute table for the active or selected layers in the map.
ArcMap Approach
◗ Right-click on the name of the layer in the Table of Contents.
◗ Pick the Open Attribute Table command.
◗ Repeat the above two steps for each layer to be processed.

11. Switch the Selection Set
This tool is used to switch or reverse the selection set for the active or selected layers in
the map. That is to say, whatever is selected will become deselected and what was not
selected will become selected. If the layer contains no selected features, then all features
in the layer will be made selected, providing a quick way of selecting all features in a layer.
This tool will also handle tables in addition to layers.
CEDRA Approach
◗ Select the layer(s) in the Table of Contents.
◗ Click this tool to switch or reverse the selection set for the active or selected layers in

the map.
ArcMap Approach
◗ Right-click on the name of the layer in the Table of Contents.
◗ Pick the Selection command.
◗ Pick the Switch Selection command.
◗ Repeat the above three steps for each layer to be processed.


